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Introduction 
 
This tutorial will introduce the use of Cadence and SpectreRF for performing circuit 
simulation in 6.776.  Cadence contains an entire design framework for IC design, 
including schematic capture, layout, circuit simulation, and verification tools.  We will be 
running Cadence Version 4.4.6 on MIT server SUN machines.  The Spectre circuit simulator 
is run in the Affirma Analog Design Environment within the Cadence design framework.  
Spectre is an advanced SPICE simulator that simulates analog and digital circuits at the 
differential equation level.  SpectreRF includes additional simulation capabilities such as 
periodic steady state (PSS), s-parameter analysis, and nonlinear noise analysis that make 
simulating RF circuits easier.  This tutorial will first explain how to get the 6.776 
Cadence environment running on MIT server.  Then, two examples will be presented that will 
help you get familiarized with the SpectreRF circuit simulator.   
 
Setting Up Cadence 
 

1. Login to an MIT Server SUN machine 
2. Type the following lines : 

add 6.776 
source /mit/6.776/setup_cadence 
You can add these lines to your .cshrc.mine file so that you do not have to repeat 
this step each time.  You must type source .cshrc.mine for the changes to take 
place. 

3. For the first time running Cadence, remove or move your ~/cds directory, then 
type : 
cadence 
Cadence version 4.4.6 should start.  A ~/cds directory will be created with the 
files needed for 6.776.     

At this point, you should see two windows titled icfb and Library Manager.  In the 
Library Manager, you will see the following pre-loaded libraries : 
 6776_Examples, 6776_Primitives, analogLib, basic 



6776_Primitives contains symbols for the NMOS and PMOS transistors we will be using 
in this class.  They have a minimum channel length of 0.18 µm.  6776_Examples contains 
the two example circuits that will be presented in this tutorial.  Example 1 contains a 
narrowband RF amplifier while Example 2 contains a high frequency oscillator circuit.  
analogLib and basic contain many useful components for circuit simulation, including 
ideal voltage and current sources, and ideal resistors, capacitors, and inductors. 
 
Creating a Schematic, Symbol, and Test-Bench 
 
The first step is to create a new library that will contain the new schematics and symbols 
to be built.   
 

1. In the Library Manager window, left-click on File -> New -> Library 
2. Type in a new library name, i.e. exampleLib, and left-click OK  
 

 
 
3. In the pop-up window, left-click on Don’t need a techfile and then left-click OK 
 

 



You should now see your new library name appear in the list of libraries of the Library 
Manager window.  To create a new schematic : 
 

1. Left-click on your library name 
2. Go to the Cell heading and type in a schematic name, i.e. example1 
3. Go to the View heading and type schematic and press enter 
4. A window called Create New File will appear.  Verify the information and left-

click OK 
 

 
 

A blank schematic capture window will now appear.  Play around with the pull-down 
menus to get familiar with the schematic capture environment.  Note that many of the 
commands have bindkeys associated with them.  The main commands you will be using .  
to build schematics are Add -> Instance , and Add -> Wire (Narrow).  Using the 
bindkeys, you can invoke these commands by simply typing i, and w, respectively.  When 
adding a wire, left-click once to start the wire router and also to stop and change 
directions.  A double left-click will end the wire, and right-clicking will modify the snap 
type for the routing (orthogonal, diagonal, etc.).   
 
Invoking Add -> Instance brings up a window that allows one to select a pre-built symbol 
using a library browser.  In order to add an NMOS transistor from the 6776_Primitives 
library : 
 

1. Type i 
2. Click on Browse and then select 6776_Primitives, nmos, symbol under Library, 

Cell, and View, respectively 
 



 
 
3. Type in the desired dimensions for the transistor Width and Length.  The units are 

in meters so remember to type in u for microns and n for nanometers when 
necessary. 

4. Place the transistor symbol in the schematic window.  You can continue adding 
additional transistor instances or different instances using the same Add Instance 
window, or stop adding instances by hitting ESC. 

5. To save any work, left-click Design -> Check and Save.  This command will 
check your schematic for errors or warnings, in addition to saving the schematic. 

 
Create the schematic shown in the screenshot below using nmos transistors from the 
6776_Primitives library and ideal resistors, capacitors, and inductors from analogLib (res, 
cap, ind).  This schematic can also be found in the 6776_Examples library.  It is named 
example1_amp.  Circuit nodes can be labeled by left-clicking Add -> Wire Name , or by 
typing l.  Pins define inputs and outputs for the schematic.  They can be added using Add 
-> Pin , or by typing p.   
 
 
 



  
 

Now we can create a symbol for this schematic that can then be placed as an instance in a 
separate test bench schematic.  In order to create a symbol from the schematic cell view : 
 

1. Click Design -> Create Cellview -> From Cellview 
 

 
 
2. Make sure symbol is entered in the To View name field 



3. The pins can be placed on the left, right, bottom, and top of the generated symbol.  
Arrange the pins in a sensible manner for use in a test bench schematic and click 
OK 

 

 
 
4. The generated symbol should now appear.  You can edit the symbol graphics as 

desired.  Click Design -> Check and Save when you are done and then click 
Window -> Close 

 
We will now create a test bench schematic for the purpose of simulating the narrowband 
amplifier found in example1_amp.  Create a new schematic in the same library.  In this 
schematic, add an instance of the symbol that you just created.  Now wire up the test 
schematic as shown in the screenshot on the next page.  A useful command that will 
allow you to descend into the symbol view or schematic view of the example1_amp 
instance for editing is Design -> Hierarchy -> Descend Edit.  The bindkey for this 
command is E.  Typing CTRL – E will pop you back up in the hierarchy.  The input and 
output voltage sources have 50 ohm source resistances associated with them.  They are 
specialized sources called ports, and can be found in the analogLib library.   
 



 
 
In this schematic, we use ideal voltage and current sources to provide the DC bias to our 
amplifier.  VDC is an ideal voltage source found in analogLib.  IDC is an ideal current 
source found in analogLib.  We tie the GND pin of the amplifier symbol to an ideal 
ground component, also found in analogLib.  In order to accurately model the gain of the 
RF amplifier, we connect the SOURCE pin of the amplifier to a 1 nH ideal inductor that 
goes to ground.  This inductance models the bondwire that is typically present in an 
integrated RF amplifier.  The input pin, VIN, connects to the input source through a 2.5 
nH inductor.  This inductance is used to match the input of the amplifier to the source 
resistance of 50 ohms.  It is physically realized using a combination of the bondwire 
inductance together with a discrete inductor or board inductance.     
 
 
 
 
 
 
 
 
 
 
 
 
 



Fill out the input port properties as follows. 
 

 
 
The input port resistance is 50 ohms.  It is being used as a sine wave source with two 
tones.  Frequency 1 is called “First” and is 5 GHz with an amplitude of Pin dBm.  Pin is a 
variable representing power in dBm that will be defined later.  Frequency 2 is called 
“Second” and has the same amplitude, but at 5.1 GHz.  The port is also being used as a 
small signal source with AC amplitude of 1. 
 
 
 
 



Fill out the output port properties as follows – 
 

 
 
The output port is numbered “2” and also has a resistance of 50 ohms.  This port is used 
as an output load.  No signals will be applied from this port. 
 
We are now ready to use Spectre to simulate our test schematic. 
 



Simulating using Affirma 
 
Left-click on Tools -> Analog Environment of the schematic window to launch the 
Affirma Analog Design Environment.  This will bring up the Affirma simulation window 
which is used to define analyses, variables, and outputs for simulations.  In order to link 
the transistors in the 6776_Primitives library to their appropriate models, we must first 
add the model files to the Affirma Setup menu.   
 

1. Left-click on Setup -> Model Libraries 
2. In the Model Library File box, type in /mit/6.776/Models/0.18u/cmos018.scs 
3. Click Add and Click OK. 

 

 
 
The next step will be to define the variables we are using in the schematic, VDD and Pin.   

1. Left-click Variables -> Edit 
2. In the Name box, type VDD. 
3. In the Value box, type 1.8. 
4. Left-click Add 

 
 

 
 

5. Repeat to add Pin with value –20 
We will now define DC and AC analyses. 



1. Left-click Analyses -> Choose … 
2. Left-click dc and left-click on the box Save DC Operating Point 
3. Left-click ac and fill out the box as follows 

 

 
 

4. Left-click OK 
 
The AC analysis will sweep frequency from 1 GHz to 9 GHz with a step size of 1 MHz.   
The Affirma simulation window should now look like this. 
 

 
 

Before we simulate,  we can save the variables and analyses defined in a state by left-
clicking Session -> Save State … and filling in a state name.  Later on, we can re-open 



the schematic, launch Affirma, and recall the settings by left-clicking Session -> Load 
State …  
 
To run a simulation and plot results –  

1. Make sure that you have left-clicked Design -> Check and Save on the schematic 
window to save any changes made to the schematic.   

2. Then, go to the Affirma window and left-click Simulation -> Netlist and Run. 
3. You can observe node voltages or device operating points by left-clicking Results 

-> Annotate -> DC Node Voltages or Results -> Annotate -> DC Operating 
Points, respectively. 

4. Left-clicking on Results -> Direct Plot will enable you to plot various AC 
parameters such as AC Magnitude, AC Phase, and AC dB20.   

5. Alternatively, you can also left-click Tools -> Calculator …  This will bring up a 
calculator window that can be used to plot various mathematical quantities from 
your circuit schematic nodes.   

 
Plot the following expressions 

1. dB20(VF(“/out”)) 
2. dB20((VF(“/in”)-1)) 

 

 
 

Based on what we have learned in class about S-parameters, you should see that these 
two quantities represent S21 and S11, respectively, for the amplifier.  We will now run 
through several other simulations using this same test schematic. 
 
 



S-Parameter Simulation 
 

1. Left-click Analyses -> Choose -> sp 
2. Under the Ports box, select the input and output ports on the schematic 
3. Select Frequency as the Sweep Variable 
4. Sweep frequency from 1 GHz to 9 GHz with a linear step size of 1 MHz 
5. Left-click yes under Do Noise and select the output and input ports 
6. Left-click OK to close the Analyses window 
7. Left-click Simulation –> Netlist and Run to run the simulation 

 

 
 
Left-click on Results -> Direct Plot -> S-Parameter … 
Plot S11 (dB20) and S21 (dB20) using the S-parameter results window. 
How do the results compare with the AC analysis we ran earlier? 
 



 
 
You can also plot the NF of the amplifier using the same S-parameter results window.  
Plot NF dB10 for the amplifier.  You should measure a noise figure of < 1.8 dB at 5 GHz. 
 

 
 

Transient Simulation 
 

1. Left-click Analyses -> Choose … -> tran 
2. Set the stop time to 60n and the accuracy defaults to moderate 
3. Left-click on Options … 
4. Under the Time Step Parameters heading, set the maxstep to 5p.  The general rule 

of thumb here is that the time step should be about 1/50 of the period of the 
frequency of interest.  In our example, the period of the 5 GHz waveform is 200 
ps. 



5. Under the Integration Method Parameters heading, set the method to gear2only.  
This integration method is accepted as being helpful for getting circuits to 
converge properly.   

6. Left-click Simulation –> Netlist and Run to run the simulation 
7. To plot transient waveforms, left-click Results -> Direct Plot -> Transient Signal 

and select nodes from the schematic to view their waveforms 
8. Plot the transient waveform at node out 

 

 
 
This waveform contains the addition of two sinusoidal signals at 5 GHz and 5.1 GHz.  
We will now use the calculator to plot the FFT of the output waveform and decipher the 
power gain of the amplifier.   
 

1. Left-click Tools -> Calculator 
2. Left-click vt and select the output node on the schematic 
3. Left-click dft … under the Special Functions box 
4. Fill out the Discrete Fourier Transform box with the following parameters 
 

 
 

5. Left-click OK and then on the Calculator window, take dB20 of the entire 
quantity by left-clicking dB20 



6. Left-click erplot to erase the existing plot and plot the FFT 
7. The FFT should indicate an output voltage power of –22.18 dBm at 5 GHz. 

 

 
 

 
 
Calculate the output power normalized to 50 ohms.  Given that the input power is –20 
dBm, what is the power gain of the amplifier? 
 
Periodic Steady State Analysis 
 

1. Left-click Analyses -> Choose … -> pss 
2. Under the list of Fundamental Tones, click on Update From Schematic 
3. You should see the frequency tones First and Second from the schematic in the 

list of tones 
4. Select Beat Frequency and left-click Auto Calculate 



5. A beat frequency of 100 MHz should appear in the box 
6. Type in 60 for number of harmonics.  This means that the PSS analysis will 

collect information on 60 harmonics of the 100 MHz beat frequency.  In other 
words, we will have information out to 6 GHz.  Since our main tones are at 5 
GHz, this should be enough harmonics.  If we wanted information on the 2nd or 
3rd harmonics of the 5 GHz input frequency, we would need to pick at least 150 
for the number of harmonics. 

7. Under Accuracy Defaults, click on moderate.  Type in 10n for the Additional 
Time for Stabilization. 

8. Left-click on Sweep and sweep Pin from –30 to 0 with a stepsize of 5. 
 

 



9. Left-click OK to close the form 
10. Left-click Simulation -> Options -> Analog 
11. Change reltol to 1e-4.  Tightening reltol will improve the simulator’s accuracy 

and push down the noise floor allowing us to resolve individual harmonic tones.  
The tradeoff is that it will increase the simulation time. 

12. Left-click Simulation -> Netlist and Run to start the simulation. 
 
In order to plot results from the PSS simulation, left-click Results -> Direct Plot -> PSS  
 
First, find the power gain with an input power of –20 dBm by clicking on the following 
settings : 

1. Plot Mode -> Replace 
2. Analysis -> pss 
3. Function -> power 
4. Select -> Port (fixed R(port)) 
5. Sweep -> spectrum 
6. Modifier -> dBm 
7. Variable Value (Pin) -> -20 
8. Select the Output port on the schematic and plot 

 

 
 
You should measure an output power of –12.15 dBm at 5 GHz.  This corresponds to a 
power gain of 7.85 dB.  How does this compare with the results computed from the 
transient analysis in the previous section? 
 



Next, find the input 1-dB compression point by clicking on the following settings in the 
PSS Results form : 

1. Plot Mode -> Replace 
2. Analysis -> pss 
3. Function –> Compression Point 
4. Select -> Port (fixed R(port)) 
5. Gain Compression (dB) -> 1 
6. Extrapolation Point -> Default (-30) 
7. Input Referred 1dB Compression 
8. 1st order Harmonic -> 50 (5G) 
9. Select the output port on the schematic 
10. Click on replot 

 
The plot should indicate an input 1-dB compression point of ~ -7 dBm. 
 

 
 
Next, find the input referred IP3 by clicking on the following settings in the PSS Results 
form : 

1. Plot Mode -> Replace 
2. Analysis -> pss 
3. Function –> IPN curves 
4. Select -> Port (fixed R(port)) 
5. Circuit Input Power -> Single Point 
6. Input Power Value (dBm) -> -20 



7. Plot -> Points 
8. Input referred IP3 
9. Order -> 3rd 
10. 3rd order Harmonic -> 49 (4.9 GHz) 
11. 1st order Harmonic -> 50 (5 GHz) 
12. Select the output port on the schematic 
13. Click replot 

 

 
 
At a Pin of –20 dBm, the plot indicates that the input referred IP3 is 3.5 dBm.  Notice that 
the curve is fairly flat up until a Pin of –15 dBm.  In general, IP3 is measured at an input 
power level around 10 dB less than the input 1-dB compression point.  Since the input 
compression point was measured to be –7 dBm, a Pin of –20 dBm is an appropriate input 
level to measure IIP3. 
 
This concludes our simulation of the narrowband RF amplifier example.  The analyses 
covered in this tutorial have been saved as session states in the example1_amp_test 
schematic found in 6776_Examples.  Open the schematic, left-click on Tools –> Analog 
Environment, and then left-click on Session -> Load State within the Affirma window to 
load either the ac, transient, pss, or s-param simulation setups. 
 



Oscillator Example 
 
Next, we will simulate an oscillator circuit using AC, transient, and PSS analyses.  Create 
a new schematic based on the following circuit diagram.  This schematic can also be 
found in the 6776_Examples library.  It is called example2_osc.  No symbol view was 
created this time.  Simulation setups for this schematic are also saved under the state 
name allsims. 
 

 
 
We will find the oscillation frequency of this circuit in three ways.  First, we will estimate 
it by doing a quick AC simulation.  Then, we will drive the circuit with an impulse-like 
current and allow the circuit to reach steady state in a transient simulation.  Finally, we 
will use SpectreRF’s PSS analysis to simulate the circuit as well as find its phase noise.  
The ideal current source between the nodes op and on will be used to provide an AC 
input as well as the impulse-like current.  Fill out the parameters of the current source as 
follows. 
 



 



Launch the Affirma Analog Design Environment by left-clicking Tools -> Analog 
Environment.  You will need to again setup the model library and define variables such as 
VDD.  Or, you can load your saved simulation state from the previous example by 
choosing Session -> Load State … from the Affirma window.  Setup the following 
simulations : 
 

1. AC Simulation 
a. Linearly Sweep from 1 GHz to 9 GHz 
b. Use a step size of 1 Mhz 

2. Transient Simulation 
a. Use a stop time of 60n 
b. Use an accuracy default of moderate 

 
Run the simulations and plot the differential output waveform (op-on) for both the AC 
and transient cases.  Calculate the oscillation frequency in the transient case by using the 
markers to measure the period of the sinusoidal waveform.  Try plotting an FFT of the 
output signal to get a measure of the oscillation frequency.  What is the difficulty with 
this approach?   
 

 
 

AC Differential Output 
 



 
 

Transient Differential Output 
 

 
 

Transient Waveform Period = 257.243 ps 



 
 

FFT of Transient Output Waveform 
 
PSS and Pnoise for Oscillator Analysis 
 
We will now use PSS to overcome some of the limitations that AC and transient 
simulations have in simulating oscillator circuits.  With PSS, we will be able to 
accurately find the oscillation frequency of the circuit in the frequency domain and 
simulate the phase noise. 
 
Setup pss and pnoise analyses according to the following forms. 
 



 
 
 
On the pss form, we will provide an estimate of the oscillation frequency under the beat 
frequency box based on our previous transient simulations.  Estimating on the high side 
of the actual oscillation frequency helps the simulator’s convergence.  We ask the 
simulator to gather information from 5 harmonics of the 4.2 GHz beat frequency.  As you 
choose more harmonics, the simulation becomes more accurate and takes longer. 
 
On the pnoise form, we choose a relative sweep of the offset frequencies for which phase 
noise will be calculated.  The offset frequency is swept from 1 kHz to 10 MHz, relative to 
the 1st harmonic of the output waveform. 



Run the simulation and plot results using Results -> Direct Plot -> PSS 
 
Find the differential output’s oscillation frequency and amplitude by using the following 
settings on the PSS Results form. 
 

1. Plot Mode -> Replace 
2. Analysis -> pss 
3. Function -> Voltage 
4. Select -> Differential Nets 
5. Sweep -> Spectrum 
6. Signal Level -> Peak 
7. Modifier -> Magnitude 
8. Choose the differential nets op and on by clicking on them in the schematic 

 
What is the oscillation frequency and oscillation amplitude? 
 

 
 
 
 
 
 



 
Now, plot the phase noise using the PSS Results form as follows. 
 

 
 
 
 

 
 
 
 

One can also separate out the individual noise contributors to the phase noise by using 
Results -> Print -> PSS Noise Summary. 
 
Experiment with this form to find the top 10 noise contributors to phase noise at a 1 MHz 
offset frequency. 



 
Printing 
 
Schematics : 
 

1) Go to Design -> Plot -> Submit on the schematic window 
2) Under Plot With , uncheck Header 
3) Click on Plot Options at the bottom right of the form 
4) Click on Send Plot Only To File and put in a filename.eps 
5) Click OK on the Plot Options form 
6) Click OK on the Submit Plot form to print 

 
Waveforms : 
 

1) Go to Window -> Hard Copy on the waveform window 
2) Under Plot With, uncheck Header 
3) Click on Send Plot Only To File and put in a filename.eps 
4) Click OK on the Hard Copy form to print 

 
 
 
Exporting Data to Matlab 
 
You can export data to Matlab indirectly by first printing it to a text file.  A general way 
to do this is to use the printvs function built into the calculator. 
 

1) Using the calculator, select the desired output signals 
2) Click on printvs in the calculator window 
3) A Printvs Range window will appear.  You can define the range of values desired 

for your output signal, i.e. a frequency range if you are printing an AC signal or a 
time range if you are printing a transient signal 

4) A Results Display window will appear.  Your data will be displayed in column 
format.  Click Window -> Print … and then select Print To -> File.  Enter a 
filename.txt. 

5) You can then import the column data from the .txt file into Matlab. 
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